DNS - Potential delays in loading DNS preferences at MUM2 data centers in the India region

Incident Report for Cloud Security Service Status

Resolved

The issue causing delays in loading DNS preferences at MUM2 has been resolved as of 16:12 UTC.
Posted Sep 07, 2025 - 16:38 UTC

Investigating

We have identified issues that may cause delays in loading DNS preferences at our Mumbai (MUM2) data center in the India region.
Our engineering team is actively working to resolve the situation in collaboration with our Internet Service Providers to minimize the impact.
We will continue to monitor the situation closely and provide timely updates as more information becomes available.
Thank you for your understanding and patience during this time.
Posted Sep 07, 2025 - 16:07 UTC
This incident affected: Umbrella Asia (DNS).