Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 11, 2026 - 17:00 UTC
Scheduled
Cisco is committed to providing you with a secure and reliable experience.To ensure our Cisco Secure Connect platform continues to meet your needs, we will be performing maintenance.
Date and Time: March 11th, 17:00 UTC to March 11th, 21:00 UTC
Impact: During this maintenance window, there is no expected impact to your existing Cisco Secure Connect services. All functionality and service availability will remain unaffected.
Data Centers Asia-1 - Narita Australia-1 - Sydney
We’re Here to Help If you have any questions or need assistance, please contact our support team.Thank you for your understanding and support.
Posted Mar 03, 2026 - 22:58 UTC
This scheduled maintenance affected: Secure Connect Asia (Meraki SD-WAN Head-End) and Secure Connect Australia (Meraki SD-WAN Head-End).