Certificate provisioning has returned to normal processing, and new connection provisioning and onboarding requests are completing successfully.
We’re Here to Help If you have any questions or need assistance, please contact our support team.
Posted Jul 31, 2026 - 21:23 UTC
Update
Certificate provisioning recovery remains in progress. Pending and new connection provisioning or customer onboarding requests may still be delayed while the backlog is being worked through.
Posted Jul 31, 2026 - 18:22 UTC
Update
Copenhagen is also experiencing delays for pending and new connection or onboarding requests due to the certificate provisioning backlog.
Posted Jul 31, 2026 - 16:42 UTC
Update
Certificate provisioning is recovering, and provisioning requests are being processed.
A backlog remains, and pending or new connection provisioning and customer onboarding requests may be delayed. We are monitoring processing and will provide the next update once normal provisioning timelines have been confirmed.
Posted Jul 31, 2026 - 16:07 UTC
Identified
We have identified certificate provisioning timeouts related to the new connection provisioning impact.
We are working to restore normal provisioning and will provide the next update as progress is made.
Posted Jul 31, 2026 - 15:57 UTC
Update
We are continuing to investigate this issue.
Posted Jul 31, 2026 - 15:23 UTC
Investigating
We are investigating an issue affecting a subset of Cisco Secure Connect customers associated with the Frankfurt and London data centers.
Affected customers may be unable to create new connections or complete new customer onboarding. Existing connected users are expected to continue using the service without disruption.
The impact is limited to new connection provisioning for customers associated with the affected head ends. We are working to restore normal provisioning and will provide the next update as more information becomes available.
Posted Jul 31, 2026 - 15:21 UTC
This incident affected: Secure Connect Europe (Data Center, IPsec Tunnel Head-End, Remote Access (Client)).