DNS - Potential delays in loading DNS preferences at CHE2 and MUM2 data centers in the India region

Incident Report for Cloud Security Service Status

Resolved

The issue causing delays in loading DNS preferences at CHE2 and MUM2 has been resolved as of 16:44 UTC.

All services are now operating normally.

We apologize for any inconvenience caused and thank you for your patience.
Posted Sep 06, 2025 - 17:50 UTC

Monitoring

The delays in preferences on DNS at CHE2 have been resolved by our engineers, and no further delays are expected there.
At MUM2, the engineering team is actively working to enhance performance.
Posted Sep 06, 2025 - 15:49 UTC

Update

We apologize for the inconvenience. We are currently experiencing the same issue at our MUM2 data center. Our teams are actively working to resolve the problem as quickly as possible.
Posted Sep 06, 2025 - 15:18 UTC

Investigating

We have identified issues that may cause delays in loading DNS preferences at our CHE2 data center in the India region.
Our engineering team is actively working to resolve the situation in collaboration with our Internet Service Providers to minimize the impact.
We will continue to monitor the situation closely and provide timely updates as more information becomes available.
Thank you for your understanding and patience during this time.
Posted Sep 06, 2025 - 14:36 UTC
This incident affected: Umbrella Asia (DNS).