Cisco Umbrella Dashboard - “Selective Decryption"

Incident Report for Cloud Security Service Status

Resolved

The issue affecting Dashboard - “Selective Decryption" has been resolved as of 15:53 UTC.

All services are now operating normally.

We apologize for any inconvenience caused and thank you for your patience.
Posted Sep 03, 2025 - 16:03 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2025 - 15:59 UTC

Identified

We have identified an issue in Cisco Umbrella Dashboard

The issue is when attempting to load up for 100 domains or more “Selective Decryption" you may face with a “loading wheel” instead of the “Domains” section.
This would prevent customers from being able to make changes to their Selective Decryption listing.
Remediation efforts are underway, and service stability has improved.

We are actively monitoring the situation and will provide a final update once the issue is fully resolved.

There is no impact for enforcement.
Posted Sep 03, 2025 - 15:47 UTC
This incident affected: Umbrella Global (SWG, Support Portal).