The service performance issues affecting our Umbrella/Secure Connect platform in the Chennai and Mumbai regions have been resolved. Our engineering team has stabilized the environment, and all services are now operating as expected.
We’re Here to Help Thank you for your patience and understanding while we worked to restore full service. If you have any questions or need assistance, please contact our support team.
Posted Apr 07, 2026 - 06:14 UTC
Update
We are still actively investigating the issue affecting service performance for our Umbrella/Secure Connect. We appreciate your patience and will provide updates as soon as new information becomes available.
Posted Apr 07, 2026 - 05:44 UTC
Investigating
We are currently investigating reports of service performance issues affecting our Umbrella/Secure Connect platform in the Chennai and Mumbai regions. Some users may experience temporary connectivity delays or intermittent service interruptions while accessing our proxy services.
Our engineering team is actively working to stabilize the environment and restore full service performance as quickly as possible. We appreciate your patience and understanding as we work to improve your Cisco Umbrella/Secure Connect experience.
Posted Apr 07, 2026 - 05:00 UTC
This incident affected: Umbrella Asia (SWG) and Secure Connect Asia (SWG).