We have successfully corrected the dashboard access issue. Service has been fully restored, and customers should now have normal access to the portal.
Outage Details: Start Time: 23:57 UTC, October 17th End Time: 00:29 UTC, October 18th
Impact Statement: During the outage window, customers were unable to access the customer portal.
This issue has now been resolved, please contact customer support if you are still experiencing any issues.
Posted Oct 18, 2025 - 01:12 UTC
Update
We are actively working on resolving the dashboard access issue. Service is currently in the process of recovering, and customers should begin to see improvements. We will continue to monitor the situation closely and provide further updates as recovery progresses. Thank you for your patience.
Posted Oct 18, 2025 - 00:43 UTC
Identified
We have identified a possible issue with access to the dashboard.
Posted Oct 18, 2025 - 00:31 UTC
This incident affected: Umbrella Global (Dashboard).