Issues Logging into Dashboard via SSO

Incident Report for Cloud Security Service Status

Resolved

The issue is now been resolved.
All services are now operating normally.
We apologize for any inconvenience caused and thank you for your patience.
Posted Oct 14, 2025 - 08:25 UTC

Investigating

We are currently investigating an issue where users are unable to log into the dashboard via SSO.
Our team is actively working to identify the cause.
Updates will be shared as soon as more information becomes available
Posted Oct 14, 2025 - 07:06 UTC
This incident affected: Umbrella Global (Dashboard).