Umbrella Support Case Issues for Some Enterprise Agreement Users

Incident Report for Cloud Security Service Status

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 22:40 UTC

Investigating

We are aware of an issue currently affecting a small subset of customers with an Enterprise Agreement who access the Secure Case Management (SCM) portal outside of the product. This issue prevents visibility of Umbrella subscriptions and restricts the ability to open support cases through SCM. Please note, this will be resolved by September 27th.

Case Submission is Still Available:

• All users can continue to open cases via Phone, Email, or directly through SCM when cross launched from the Umbrella dashboard without any impact.

Recommended Workarounds:

• Please continue to open cases through the SCM portal when cross launched from the Umbrella dashboard, Phone or Email as usual.

• You can also bookmark your unique Umbrella cross launch link to SCM. This link can be found by selecting 'Support' from the Umbrella dashboard and is specific to your account.

We appreciate your understanding as we work to resolve this issue. Thank you for your patience.

This issue can be tracked on community.cisco.com by following this link: https://community.cisco.com/t5/umbrella-announcements/umbrella-support-case-issues-for-some-enterprise-agreement-users/ta-p/5323434
Posted Aug 22, 2025 - 22:39 UTC
This incident affected: Umbrella Global (Support Portal).