The issue affecting our Secure Connect services in US-East has been resolved as of 16:50. All services are now operating normally. We apologize for any inconvenience caused and thank you for your patience.
Posted Oct 20, 2025 - 16:54 UTC
Update
The engineering team has resolved the DNS issue, and DNS is now functioning as expected. Work is ongoing by the engineering teams to mitigate issues affecting the other services.
Posted Oct 20, 2025 - 16:32 UTC
Update
Our engineering team are still working on the investigation and mitigation. Updates and additional details will be provided as more information becomes available.
Posted Oct 20, 2025 - 16:13 UTC
Investigating
There is a potential issue impacting to some Umbrella and Secure Connect in US-East region.
Our engineers are currently working to confirm the impact, identify the root cause and implement a resolution. Updates and additional details will be provided as new information becomes available.
Posted Oct 20, 2025 - 14:53 UTC
This incident affected: Secure Connect North America (DNS, IPsec Tunnel Head-End, Meraki SD-WAN Head-End, SWG).