Cisco Umbrella - Certificate errors with HTTPS inspection - US (Los Angeles and Miami)

Incident Report for Cloud Security Service Status

Resolved

This issue has been resolved.

Cisco Umbrella customers using HTTPS inspection in the Los Angeles and Miami regions should no longer experience certificate warnings or errors when accessing websites or applications inspected by Cisco Umbrella.

Thank you for your patience. If you continue to experience issues, please contact Cisco Customer Support.
Posted Jul 21, 2026 - 23:04 UTC

Investigating

We are investigating reports of certificate errors affecting some Cisco Umbrella customers using HTTPS inspection in the Los Angeles and Miami regions.

Affected customers may experience certificate warnings or errors when accessing certain websites or applications inspected by Cisco Umbrella.

Our engineering teams are actively investigating and gathering additional diagnostic information. Updates and additional details will be provided as new information becomes available.

We appreciate your patience and understanding during this time.
Posted Jul 21, 2026 - 22:08 UTC
This incident affected: Umbrella North America (SWG).