Potential impact to Umbrella Dashboard reports.

Incident Report for Cloud Security Service Status

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 01:37 UTC

Identified

The issue has been identified, and our engineers are deploying a fix to resolve it. No impacts are expected during the deployment.
The deployment is expected to be completed by approximately 01:30 UTC.
Posted Oct 23, 2025 - 00:13 UTC

Investigating

We are currently investigating an issue affecting Dashboard report exports. Some data results may not be fully displayed for DNS, Firewall and Web searches.


Updates will be provided as more information becomes available.
Posted Oct 22, 2025 - 18:54 UTC
This incident affected: Umbrella Global (Dashboard).