Palo Alto Cloud Connectors

Incident Report for Cloud Security Service Status

Resolved

The issue affecting Cloud Connector services in the Palo Alto data center has been fully resolved as of 04:58 UTC on August 1, 2025. All services have returned to normal operation and traffic flows have been restored.

We appreciate your patience while we worked to resolve this issue.
Posted Aug 01, 2025 - 12:59 UTC

Investigating

We have identified the issue affecting the Cloud Connector services in the Palo Alto data center. To minimize disruption during business hours, we will bring the Cloud Connector services for the Palo Alto data center back into rotation starting July 31 at 17:30 PT (August 1 at 00:30 UTC). The process is expected to take approximately one hour. We will provide periodic updates as new information becomes available.
Posted Jul 31, 2025 - 23:07 UTC
This incident affected: Secure Connect North America (Meraki SD-WAN Head-End).