Issues with the Remote Browser isolation in Ashburn and Stockholm

Incident Report for Cloud Security Service Status

Resolved

Issue is also resolved in Stockholm.
Posted Oct 24, 2025 - 19:59 UTC

Update

Issue was identified and resolved in Ashburn as of 19:39 UTC.
We are troubleshooting the issue in Stockholm
Posted Oct 24, 2025 - 19:52 UTC

Investigating

Issues with the Remote Browser isolation in Ashburn and Stockholm

Our engineers are currently working to confirm the impact, identify the root cause and implement a resolution.
Updates and additional details will be provided as new information becomes available.
Posted Oct 24, 2025 - 19:46 UTC
This incident affected: Umbrella Europe (Remote Browser Isolation) and Umbrella North America (Remote Browser Isolation).