Services are now fully recovered. If you are experiencing any VPN tunnel issues, please reconnect the tunnel. For any other problems, please contact customer support for further assistance.
We apologize for any inconvenience caused.
Posted Oct 20, 2025 - 10:44 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:20 UTC
Monitoring
Services are fully recovered. Customers should no longer be experiencing any issues. We will continue to monitor the environment to ensure complete restoration.
We will provide another update in 15 minutes.
Posted Oct 20, 2025 - 10:18 UTC
Update
Services are now almost fully recovered. Customers should no longer be experiencing any issues. We will continue to monitor the environment to ensure complete restoration.
We will provide another update in 15 minutes or sooner if additional information becomes available.
Posted Oct 20, 2025 - 09:53 UTC
Update
We are seeing services beginning to recover. Our team is actively monitoring the situation to ensure full restoration.
We will provide another update in 15 minutes or sooner if more information becomes available.
Thank you for your continued patience.
Posted Oct 20, 2025 - 09:31 UTC
Update
Impact Update: * This incident impacts Secure Connect customers in all regions. * On the Meraki dashboard Remote Access VPN configurations may not be displayed. * Established VPN tunnels continue to function normally. * New VPN tunnels will fail to establish.
Root Cause: Our cloud infrastructure partner has identified the root cause of the issue on their side and is in the process of rolling out a fix. They are still working towards full resolution and will share an estimated time for full recovery as soon as it is available.
Posted Oct 20, 2025 - 09:24 UTC
Identified
Our cloud infrastructure partner has identified the root cause of the issue on their end and is in the process of rolling out a fix. They are still working towards full resolution and will share an estimated timeframe for full recovery as soon as it is available.
We will continue to monitor the situation closely and provide further updates as new information becomes available.
Thank you for your patience.
Posted Oct 20, 2025 - 09:02 UTC
Investigating
We are currently investigating an issue impacting the US East Coast region. Remote Access VPN and Firewall administrators may experience that changes made in the UI to their VPN profiles are not taking effect.
Impact: * Changes to VPN profiles made via the UI may not be applied. * Some elements on the Dashboard may not be loading properly. * On the Meraki dashboard Remote Access VPN configurations may not be displayed. * Established VPN tunnels continue to function normally. * New VPN tunnels may fail to establish.
Root Cause: Our initial investigation indicates the issue is related to an underlying problem with one of our cloud infrastructure providers. We have escalated this incident to their team and are actively working with them toward resolution.
Updates and additional details will be provided as new information becomes available.
Posted Oct 20, 2025 - 08:48 UTC
This incident affected: Secure Connect Africa (Firewall, IPsec Tunnel Head-End), Secure Connect Asia (Firewall, IPsec Tunnel Head-End), Secure Connect Australia (Firewall, IPsec Tunnel Head-End), Secure Connect Europe (Firewall, IPsec Tunnel Head-End), Secure Connect North America (Firewall, IPsec Tunnel Head-End), and Secure Connect South America (Firewall, IPsec Tunnel Head-End).