Connectivity Disruptions Impacting Customers in Prague Data Center

Incident Report for Cloud Security Service Status

Resolved

The issue affecting connectivity inPrague has been resolved as of 23:47 UTC.
All services are now operating normally.

We apologize for any inconvenience caused and thank you for your patience.
Posted Nov 07, 2025 - 23:51 UTC

Investigating

Our team has identified connectivity issues affecting customers connecting to our Data Centers in Prague starting at 22:20 UTC. Traffic is currently being routed through the redundant hub.
Our team is currently investigating.
Posted Nov 07, 2025 - 23:28 UTC
This incident affected: Umbrella Europe (Cloud Delivered Firewall).