RBI degradation in Stockholm

Incident Report for Cloud Security Service Status

Resolved

The instability affecting RBI in Stockholm has been resolved as of 12:50 UTC.
All services are now fully operational.
We apologize for any inconvenience this may have caused and appreciate your patience during this time.
Posted Nov 04, 2025 - 14:55 UTC

Investigating

We are aware of an issue intermittently affecting remote browser isolation in our Stockholm data centre. Users may see Remote Browser Isolation fail open until the issue is mitigated. We will provide an update when the issue is mitigated.
Posted Nov 04, 2025 - 11:33 UTC
This incident affected: Umbrella Europe (Remote Browser Isolation).